POJ 1837 Balance [动态规划——完全背包]

题干

Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.
Output

The output contains the number M representing the number of possibilities to poise the balance.
Sample Input

2 4
-2 3
3 4 5 8
Sample Output

2

题解

/**
*这个题目,起初只考虑到了用平衡量结合动态规划做,但是还是没有想明白,
*包括dp数组初始化什么的,后来转移方程搞出来了,总结有以下几点:
*1,不可禁锢思维,每个题目都有他自己的特殊之处,特殊情况特殊讨论
*2,要把整个程序运行的过程在脑子里面过一遍,从初始化到出结果都要在脑子里面过一遍
*想清楚了才可以
*3,做的比较好的就是,在纸上用动态转移方程演算了一下样例,这让我避免了重复修改代码
*4,应该看清题意:#所以砝码都要用上#每个挂钩可以挂无限个#
*/
#include<cstdio>
const int N = 16000;//G*砝码最大重量*杠杆最大臂长=7500,所以范围是-7500~7500,
//为了计算方便,统一用shiftint)偏移到0~15000
const int M = 25;
int shift(int a){
  return a+7500;
}
int dp[25][N];
int main(){
  int C,G,cs[M],gs[M];
  while(~scanf("%d%d",&C,&G)){
    for(int i=1;i<=C;i++)scanf("%d",&cs[i]);
    for(int i=1;i<=G;i++)scanf("%d",&gs[i]);
    for(int i=-7500;i<=7500;i++)for(int j=0;j<M;j++){
       dp[j][shift(i)] = 0;//初始化
    }
    for(int k=1;k<=C;k++){
       dp[1][shift(cs[k]*gs[1])] = 1;//只挂第一个砝码,各种挂法下的情况
    }
    for(int i=2;i<=G;i++){
       for(int j=-7500;j<=7500;j++){
           for(int k=1;k<=C&&shift(j-cs[k]*gs[i])>=0;k++){
              dp[i][shift(j)] += dp[i-1][shift(j-cs[k]*gs[i])];//转移方程
              //dp[i][j]代表前i个砝码在平衡量为j的情况的下的方案数,要记得用+=,
              //因为可能之前就有结果可以用了,
           }
       }
    }
    printf("%d\n",dp[G][shift(0)]);
  }
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值