然而沼跃鱼早就看穿了一切

问题:

描述


fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入
The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB
样例输出
The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

解法:

    该题的思路很简单,用一个指针在原字串中移动,将所有非要找的字串拷贝到一个新的字串中,而将要找的字串替换为要替换的字串。

	#include<iostream>
	#include<string>

	using namespace std;

	char changeLB(char src){
		if(src >= 'a' && src <= 'z'){
			return src - ('a' - 'A');
		}else{
			return src + 'a' - 'A';
		}
	}

	string execReplace(string src, string tofind = "marshTomp", 
						string toreplace = "fjxmlhx"){
		int i = 0;
		string result;
		while(i < src.length()){
			if(src[i] != tofind[0] && src[i] != changeLB(tofind[0])){
				result += src[i];
				i++;
			}else{
				int j = 0;
				int tmp = i;
				while(i < src.length() && j < tofind.length()){
					if(src[i] == tofind[j] || src[i] == changeLB(tofind[j])){
						i++;
						j++;
					}else{
						break;
					}
				}
				if(j == tofind.length()){
					result += toreplace;    
				}else{
					result += src[tmp];
					i = tmp + 1;
				}
			}
		}
		return result;
	}

	int main(int argc, char **argv){
		string tochange;
		while(getline(cin, tochange)){
			cout << execReplace(tochange) << endl;    
		}

		return 0;
	}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值