Sequential game

2291: Sequential game

时间限制: 1 Sec   内存限制: 128 MB
提交: 18   解决: 7
[ 提交][ 状态][ 论坛]

题目描述

  Sequential detector is a very important device in Hardware experiments. But is very difficult for many students such as HeroWei. In nearest days, his teacher Miss Fang let him simulate sequence detector. But there many sequence here ,and Miss Fang add the difficulty that when she give HeroWei a sequence and a string ,you must tell her how many string here in this sequence. But now Miss Fang simplified the problem for HeroWei, she just give Herowei a sequence and let HeroWei play a game with it.
  When comes a character , it must compare with the rightmost one of sequence, if it's the same with the coming characters ,the coming one just join the string. Most the right side. Otherwise all the characters in the sequence must change its value, 0 to 1 and 1 to 0,then the coming one add to its right side. Here is an example, if there is a sequence '110' when comes a character 0,the sequence become '1100' at last, if comes a character 1,the sequence become '0011' at last. 
     It's very difficult for HeroWei to play the game. Can you help him? 

输入

  Each line contains a composed by a string of 0s and 1s.the input is ended by EOF.

输出

  For each given sequence you just play with this string as descripted above.Output a line contains two integers ,which are the number of 0s and 1s in the sequence after the game.

样例输入

011011111010

样例输出

1 03 00 44 0
错了n多遍,终于过了,看代码:
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    char str1[1010],str2[1010];
    while(scanf("%s",str1)!=EOF){
        int i,j;
        str2[0]=str1[0]; str2[1]='\0';
        for(i=1;i<strlen(str1);i++){
            if(str2[i-1]!=str1[i])
                for(j=0;j<i;j++)
                    str2[j]=!(str2[j]-'0')+'0';
            str2[i]=str1[i];
            str2[i+1]='\0';
        }
        int sum0=0,sum1=0;
        for(i=0;i<strlen(str2);i++)
            if(str2[i]=='0') sum0++;
            else sum1++;
        printf("%d %d\n",sum0,sum1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值