HDU1258:Sum It Up

点击打开题目链接

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3062    Accepted Submission(s): 1538


Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
      
      
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 

Sample Output
      
      
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
 

Source
 

Recommend
JGShining
 


====================================题目大意======================================


输出用给定的S个正整数相加得到正整数N的所有加式方案,按照优先选取大数作为因子的规则输出加式。


====================================算法分析======================================


简单的DFS+回溯。

需要注意的是:对于每个DFS过程所在的数字而言,应该枚举其在加式中的出现次数(把不出现当做作为0次处理)。

而为了符合输出规则:DFS应当从大数开始(好在题目给出的已经是一个非降序排列的数组了),枚举某个数字在加式中出现的次数

也应该从多到少。

一点小小的优化:若当前的加式的数值已经大于N则不必继续DFS。


=======================================代码=======================================




#include<stdio.h>

int N,S,SaveEqu[1005],EquLen,FactorNum;

bool GetAns;

struct DIGIT  { int Val,Num; } Factor[105];

void DFS(int FactID,int CurSum)
{
	if(CurSum==N)                              
	{
		GetAns=true;
		for(int i=0;i<EquLen;++i)
		{
			printf("%d%c",SaveEqu[i],i+1<EquLen?'+':'\n');
		}
		return;
	}
	if(FactID>=FactorNum) { return; }
	for(int n=Factor[FactID].Num;n>=0;--n)    
	{
		int tmp=Factor[FactID].Val*n+CurSum;
		if(tmp>N) { continue; }                
		for(int i=1;i<=n;++i)
		{	
			SaveEqu[EquLen++]=Factor[FactID].Val;
		}
		DFS(FactID+1,tmp);                     
		EquLen-=n;
	}
}

void ReaData()
{
	scanf("%d",&S);
	GetAns=false;
	EquLen=0;
	FactorNum=0;
	for(int i=0;i<S;++i)
	{
		int tmp;
		scanf("%d",&tmp);
		if(FactorNum&&tmp==Factor[FactorNum-1].Val)
		{
			++Factor[FactorNum-1].Num;
		}
		else
		{
			Factor[FactorNum].Val=tmp;
			Factor[FactorNum].Num=1;
			++FactorNum;
		}
	}		
}

int main()
{
	while(scanf("%d",&N)==1&&N)
	{
		ReaData();
		printf("Sums of %d:\n",N);
		DFS(0,0);
		if(!GetAns) { printf("NONE\n"); }
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值