HDU 1258 Sum It Up (搜索)

31 篇文章 0 订阅

链接http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1004&cid=34750

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

DFS题,和那个Square题做起来相似,即累加,小于sum的时候进入下一层,满足条件时进行输出

输出时会有重复的,我水一点,把要输出的数组转化成字符串,再用map判断是否输出过。。应该

有简单的方法

#include<iostream>
#include<map>
#include<string.h>
#include<stdio.h>
using namespace std;
int a[30], b[30], c[30];
int flag = 0, sum, n;
map<string, int>mp;
void dfs(int d, int now, int begin){      //d是加入数组的数目,now是目前的总和,begin是a数组的起点 
	if (now == sum){
		string k;
		flag = 1;
		for (int i = d; i >= 1; i--)
			k.push_back(b[i] + '0');          //防止重复输出 
		if (mp[k] == 0){
			mp[k] = 1;
			cout << b[1];
			for (int i = 2; i <= d; i++)
				cout << "+" << b[i];
			cout << endl;
		}
	}
	else {
		for (int i = begin; i < n; i++)
		{
			int next = now + a[i];         //next为当前的数字加上a[i] 
			if (c[i] == 0 && next <= sum)    //如果小于sum进入下一层 
				c[i] = 1, b[d + 1] = a[i], dfs(d + 1, next, i + 1), c[i] = 0;   //熟悉的操作 
		}
	}
}
int main(){
	while (cin >> sum >> n && (sum || n))
	{
		printf("Sums of %d:\n", sum);
		memset(c, 0, sizeof(c));
		flag = 0;
		for (int i = 0; i < n; i++)
			cin >> a[i];
		dfs(0, 0, 0);
		if (flag == 0)cout << "NONE" << endl;
	}
	return 0;
}

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值