第十六周oj刷题——Problem C: B 求类中数据成员的最大值-类模板

Description

声明一个类模板,类模板中有三个相同类型的数据成员,有一函数来获取这三个数据成员的最大值。

Input

分别输入3个整数,3个浮点数,3个字符

Output

 3个整数的最大值
3个浮点数中的最大值
3个字符中的最大值

Sample Input

9 5 6
1.1 3.4 0.9
a b c

Sample Output

9
3.40
c

 

/* All rights reserved.
 * 文件名称:test.cpp
 * 作者:陈丹妮
 * 完成日期:2015年 6 月 25 日
 * 版 本 号:v1.0
 */
#include <iostream>
#include <iomanip>
using namespace std;
template<class numtype>
class Max
{
public:
Max(numtype a,numtype b,numtype c);
numtype getMax();
private:
numtype x,y,z;
};

//******************** begin ********************
template<class numtype>
Max<numtype>::Max(numtype a,numtype b,numtype c)
{
    x=a;
    y=b;
    z=c;
}
template<class numtype>
numtype Max<numtype>::getMax()
{
    numtype max=x;
    if(x<y)
        max=y;
    if(z>max)
        max=z;
    return max;
}
//********************* end ********************

int main()
{
int i1,i2,i3;
cin>>i1>>i2>>i3;
Max<int> max1(i1,i2,i3);
cout<<max1.getMax()<<endl;
float f1,f2,f3;
cin>>f1>>f2>>f3;
Max<float> max2(f1,f2,f3);
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
cout<<max2.getMax()<<endl;
char c1,c2,c3;
cin>>c1>>c2>>c3;
Max<char> max3(c1,c2,c3);
cout<<max3.getMax()<<endl;
return 0;
}


 
 
学习心得:这道题是类模板的题,我得熟练的掌握这类题目的格式,这样才不会出错误,所以继续刷题,继续努力吧!!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值