HDU 2829 DP斜率优化 解题报告

Lawrence

Problem Description

T. E. Lawrence was a controversial figure during World War I. He was a British officer who served in the Arabian theater and led a group of Arab nationals in guerilla strikes against the Ottoman Empire. His primary targets were the railroads. A highly fictionalized version of his exploits was presented in the blockbuster movie, “Lawrence of Arabia”.
You are to write a program to help Lawrence figure out how to best use his limited resources. You have some information from British Intelligence. First, the rail line is completely linear—there are no branches, no spurs. Next, British Intelligence has assigned a Strategic Importance to each depot—an integer from 1 to 100. A depot is of no use on its own, it only has value if it is connected to other depots. The Strategic Value of the entire railroad is calculated by adding up the products of the Strategic Values for every pair of depots that are connected, directly or indirectly, by the rail line. Consider this railroad:
这里写图片描述
Its Strategic Value is 4*5 + 4*1 + 4*2 + 5*1 + 5*2 + 1*2 = 49.
Now, suppose that Lawrence only has enough resources for one attack. He cannot attack the depots themselves—they are too well defended. He must attack the rail line between depots, in the middle of the desert. Consider what would happen if Lawrence attacked this rail line right in the middle:
这里写图片描述
The Strategic Value of the remaining railroad is 4*5 + 1*2 = 22. But, suppose Lawrence attacks between the 4 and 5 depots:
这里写图片描述
The Strategic Value of the remaining railroad is 5*1 + 5*2 + 1*2 = 17. This is Lawrence’s best option.
Given a description of a railroad and the number of attacks that Lawrence can perform, figure out the smallest Strategic Value that he can achieve for that railroad.

Input

There will be several data sets. Each data set will begin with a line with two integers, n and m. n is the number of depots on the railroad (1≤n≤1000), and m is the number of attacks Lawrence has resources for (0≤m < n). On the next line will be n integers, each from 1 to 100, indicating the Strategic Value of each depot in order. End of input will be marked by a line with n=0 and m=0, which should not be processed.

Output

For each data set, output a single integer, indicating the smallest Strategic Value for the railroad that Lawrence can achieve with his attacks. Output each integer in its own line.

Sample Input

4 1
4 5 1 2
4 2
4 5 1 2
0 0

Sample Output

17
2

【解题报告】
定义dp[i][j]表示将前j个数分成i组所得到的价值,sum[i]表示前i个数之和,w[i]表示前i个数分成一组的价值,则:
dp[i][j] = min{dp[i-1][k] + val(k+1, j)} (i-1<=k < j),val(k+1, j)为将第k+1~j个数分为一组的价值。对该式变形得:
dp[i][j] = min{dp[i-1][k] + w[j] - w[k] - sum[k]*(sum[j] - sum[k])}
= min{dp[i-1][k] - w[k] + sum[k]*sum[k] - sum[k]*sum[j]} + w[j] (i-1<=k < j).
然后,就可以对该dp进行斜率优化。
不过这道题也可以用四边形优化

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 10010

int n,m;
int a[N],sum[N],w[N];
int dp[N][N],q[N];
int head,tail;

int GetY(int x,int j,int i)  
{  
    return dp[x][i]-w[i]+sum[i]*sum[i]-(dp[x][j]-w[j]+sum[j]*sum[j]);   
}  
int GetX(int j,int i)  
{  
    return sum[i]-sum[j];  
}  
int main()  
{  
    while(scanf("%d%d", &n, &m) != EOF) 
    {  
        if(n==0&&m==0) break;  
        sum[0]=0;  
        w[0]=0;  
        for(int i=1;i<=n;++i) 
        {  
            scanf("%d",&a[i]);  
            sum[i]=sum[i-1]+a[i];  
            w[i]=w[i-1]+sum[i-1]*a[i];   
        }  
        for(int i=1;i<=n;++i) 
            dp[1][i]=w[i];    
        for(int i=2;i<=m+1;++i) 
        {  
            head=tail=0;  
            q[tail++]=i-1;  
            for(int j=i;j<=n;++j) 
            {  
                while(tail-head>=2&&(GetY(i-1,q[head],q[head+1])<sum[j]*GetX(q[head],q[head+1])))
                    head++;
                dp[i][j]=dp[i-1][q[head]]+w[j]-w[q[head]]-sum[q[head]]*(sum[j]-sum[q[head]]);  
                while(tail-head>=2&&(GetY(i-1,q[tail-2],q[tail-1])*GetX(q[tail-1],j)>=GetX(q[tail-2],q[tail-1])*GetY(i-1,q[tail-1],j))) 
                    tail--;
                q[tail++]=j;  
            }  
        }  
        printf("%d\n",dp[m+1][n]);    
    }  
    return 0;  
}  

让我看到你们的双手

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值