POJ 3080 Blue Jeans(暴力枚举+KMP 类似POJ 3450)

Blue Jeans
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9909 Accepted: 4180

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT
 
                 题目大意:找最长连续公共子串,串的长度小于3输出no sign...否则有长度相同的输出字典序最小的。

           解题思路:将第一个串有长度从大到小开始枚举求next数组,然后再用后面所有的串跟前面第一个匹配。

           题目地址:Blue Jeans

AC代码:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
int next[62],n;
char a[12][62];
int lena0; //模式串的长度
//我的思路是用第一个字符串当模式串,然后再枚举长度由大到小求next匹配

void getnext(int sta,int len)
{
     int i,j;
     len=sta+len;   //相对位置变成绝对位置
     next[sta]=sta,next[sta+1]=sta;
     for(i=sta+1;i<len;i++)
     {
          j=next[i];
          while(j!=sta&&a[0][i]!=a[0][j])
               j=next[j];
          if(a[0][i]==a[0][j])
               next[i+1]=j+1;
            else
               next[i+1]=sta;
     }
}

int KMP(int sta,int len)
{
     int i,j,k;
     len=sta+len;
     for(k=1;k<n;k++)   //后面的串都和第一个串的子串匹配
     {
          int flag=0;
          j=sta;
          for(i=0;i<60;i++)
          {
               while(j!=sta&&a[k][i]!=a[0][j])
                    j=next[j];
               if(a[k][i]==a[0][j])
                    j++;
               if(j==len)
               {
                  flag=1;
                  break;
               }
          }
          if(flag==0)    //有一个没有匹配,便返回0
               return 0;
     }
     return 1;
}

int main()
{
     int i,j,k,T;
     scanf("%d",&T);
     while(T--)
     {
          scanf("%d",&n);
          if(n==0)
             break;
          for(i=0;i<n;i++)
               scanf("%s",a[i]);
          lena0=60;
          char res[62]="";
          for(i=lena0;i>=1;i--)  //从长度lena0开始往下枚举
          {
             int flag1=0;    //长度为i的是否存在
             for(j=0;j<=lena0-i;j++)  //模式串分解的起始位置
             {
                 getnext(j,i);
                 if(KMP(j,i))
                 {
                      if(strlen(res)==0||strncmp(res,a[0]+j,i)>0)
                      {  //匹配串为空或者字典序排在后面就交换
                           strncpy(res,a[0]+j,i);
                           res[i]='\0';
                      }
                      flag1=1;
                 }
             }
             if(flag1)   //长度为i的存在
             {
                  if(i>=3) printf("%s\n",res);
                  break;
             }
          }
          if(i<3)  //匹配的长度小于3
             printf("no significant commonalities\n");
     }
     return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值