Blue Jeans
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 23660 | Accepted: 10459 |
Description
The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.
As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.
A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.
Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input
Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
- A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
- m lines each containing a single base sequence consisting of 60 bases.
Output
For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3 2 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA 3 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA 3 CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT
Sample Output
no significant commonalities AGATAC CATCATCAT
Source
这题给定啦长度,只需要在第一个字符串中枚举它的子字符串,然后和其它的字符串进行匹配(用kmp进行匹配),如果全部都能匹配成功,就记录这个字符串
其实这题的做法稍微的改一下,还可以做POJ 3450 Corporate Identity
https://blog.csdn.net/qq_43813140/article/details/100094948
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<string.h>
#include<iterator>
#include<vector>
#include<stdlib.h>
#include<map>
#include<queue>
#include<stack>
#include<set>
#include<sstream>
#define lowbit(x) (x&(-x))
typedef long long ll;
using namespace std;
const int N = 15,M = 65,L = 60;
bool kmp(char s[],char p[])
{
int Next[M];
Next[0] = -1,Next[1]=0;
int plen = strlen(p),i=0,j,slen = strlen(s);
while(++i<plen-1)
{
j = Next[i];
while(j!=-1&&p[i]!=p[j])
j = Next[j];
Next[i+1] = j+1;
}
i = j =0;
while(i<slen&&j<plen)
{
if(j==-1||s[i]==p[j])++i,++j;
else
j = Next[j];
}
return j==plen;
}
int main()
{
int t,n,flag;
char s[N][M],tans[M],ans[M];
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
flag = 0;
for(int i=0;i<n;i++)
scanf("%s",s[i]);
for(int lans = L;lans>2&&flag==0;--lans)//枚举子字符串的长度
{
strcpy(ans,"ZZ");
for(int i=0,j,k;i+lans<=L;++i)//子字符串的在原字符串中第一个位置
{
for(j = 0;j<lans;++j)
tans[j] = s[0][i+j];//记录子字符串
tans[j] = '\0';
for(k = 1;k<n;k++)
if(!kmp(s[k],tans)) break;//进行匹配
if(k==n)//匹配成功
{
if(strcmp(ans,tans)>0)strcpy(ans,tans);//记录子字符串
flag = 1;
}
}
}
if(flag==1)
printf("%s\n",ans);
else
printf ("no significant commonalities\n");
}
return 0;
}