洛谷P1308 统计单词数

题目简介

题目描述
      一般的文本编辑器都有查找单词的功能,该功能可以快速定位特定单词在文章中的位置,有的还能统计出特定单词在文章中出现的次数。


      现在,请你编程实现这一功能,具体要求是:给定一个单词,请你输出它在给定的文章中出现的次数和第一次出现的位置。注意:匹配单词时,不区分大小写,但要求完全匹配,即给定单词必须与文章中的某一独立单词在不区分大小写的情况下完全相同(参见样例1 ),如果给定单词仅是文章中某一单词的一部分则不算匹配(参见样例2 )。


输入输出格式


输入格式:
输入文件名为stat.in ,2 行。


第1 行为一个字符串,其中只含字母,表示给定单词;


第2 行为一个字符串,其中只可能包含字母和空格,表示给定的文章。


输出格式:
输出文件名为stat.out 。


只有一行,如果在文章中找到给定单词则输出两个整数,两个整数之间用一个空格隔开,分别是单词在文章中出现的次数和第一次出现的位置(即在文章中第一次出现时,单词首字母在文章中的位置,位置从 0 开始);如果单词在文章中没有出现,则直接输出一个整数-1。


输入输出样例


输入样例#1:
To
to be or not to be is a question
输出样例#1:
2 0


输入样例#2:
to
Did the Ottoman Empire lose its power at that time


输出样例#2:
-1

思路

如果直接暴力扫的话,最后的样例会超时,所以最好的解决方案是采用STL的函数,效率较高。

C++代码样例

#include <cstdio>
#include <cstdlib>
#include <string>
#include <iostream>
#include <functional>
#include <algorithm>

using namespace std;

int main(void)
{
    int count = 1, firstpos = 0, nextpos = 0;
    string target = "";
    string source = "";
    getline(cin, target);
    getline(cin, source);
    target = " " + target + " ";
    source = " " + source + " ";
    transform(target.begin(), target.end(), target.begin(), (int(*)(int))std::tolower);
    transform(source.begin(), source.end(), source.begin(), (int(*)(int))std::tolower);
    if(source.find(target) == string::npos)
    {
        cout << "-1" << endl;
        return 0;
    }
    else
    {
        firstpos = source.find(target);
        nextpos = firstpos;
        nextpos = source.find(target, nextpos + 1);
        while(nextpos != string::npos)
        {
            count++;
            nextpos = source.find(target, nextpos + 1);
        }
    }
    cout << count << " " << firstpos;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值