浙江大学PAT_甲级_1054. The Dominant Color (20)

题目链接:点击打开链接

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
我的C++程序:

#include<iostream>
#include<map>
using namespace std;
int main()
{
	int m, n, i = 0;
	map<int, int>ma;//map的值统计数字出现次数
	int temp,max_value=0;
	scanf("%d %d", &m, &n);
	for (i = 0;i < m*n;i++)
	{
		scanf("%d", &temp);//输入数字
		ma[temp]++;
	}
	auto it = ma.begin();
	for (;it != ma.end();it++)//遍历map
	{
		if (it->second > max_value)
		{
			temp= it->first;记录出现次数最多的数字
			max_value = it->second;//寻找最大出现次数
		}
	}
	printf("%d",temp);
	//system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值