浙江大学PAT_甲级_1048. Find Coins (25)

题目链接:点击打开链接

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution
我的C++代码:

#include<iostream>
using namespace std;
int main()
{
	int n, m;
	int coins[1001] = {0};//coins[]数组存储硬币数
	cin >> n >> m;
	while (n--)
	{
		int temp;
		cin >> temp;
		coins[temp]++;//记录各个面值的硬币出现次数
	}
	for (int i = 1; i <=m/2; ++i)// i <= m / 2只要判断前一半硬币数量
	{
		coins[i]--;//同一个面值的硬币已经使用了一次,数量-1
		coins[m - i]--;
		if (coins[i] >=0 && coins[m - i] >=0)//对于x面值硬币,查找m-x面值硬币是否出现
		{
			printf("%d %d\n", i, m - i);//有合适的结果则输出
			return 0;//然后直接退出,后面的No Solution不会输出
		}
	}
	printf("No Solution\n");//没有合适的结果
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值