【PAT】1048.Find Coins (25)

题目描述

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

翻译:Eva喜欢收集来自宇宙各地的硬币,包括一些其他的星球比如火星。一天她在一个可以支付所有类型的硬币的购物广场逛街。但是,每次支付都有一个很奇怪的要求,她只能用两个硬币支付且价值要一模一样。由于她带了10^5个硬币,她十分需要你的帮助。你需要告诉她,对于给出的价格,她是否可以找到两个硬币去支付。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括2个正整数N(<=10^5)代表硬币总数,和M(<=10^3),代表Eva需要支付的价格。第二行包括N个硬币的表面价值,均为不超过500的正整数。一行内所有数字之间都用空格隔开。

OUTPUT FORMAT

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output “No Solution” instead.

翻译:对于每组输入数据,输出一行两个价值V1和V2(用空格隔开),V1 + V2 = M and V1 <= V2。如果答案不唯一,输出最小的V1。如果没有结果,输出”No Solution”。


Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11


Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution


解题思路

由于这道题M<=1000,N<=100000,所以选择用哈希记录数字M出现次数,然后从1—M/2枚举,判断i和M-i是否出现过。注意如果i==M-i,则i出现次数要大于等于2次。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,M,m[1010];
int main(){
    scanf("%d%d",&N,&M);
    int a;
    for(int i=0;i<N;i++){
        scanf("%d",&a);
        m[a]++;
    }
    int flag=0;
    for(int i=1;i<=M/2;i++){
        int temp=M-i;
        if(temp==i&&m[temp]>=2||(temp!=i&&m[temp]&&m[i])){
            printf("%d %d\n",i,temp);
            flag=1;
            break;      
        }   
    }
    if(!flag)printf("No Solution\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值