湖南中医药大学2017年集训队第四场选拔赛-Problem F: Virtual Friends

Problem F: Problem C: Virtual Friends

Time Limit: 5 Sec Memory Limit: 128 MB
Submit: 106 Solved: 55
[Submit][Status][Web Board]
Description

Problem C: Virtual Friends

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends’ friends, their friends’ friends’ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person’s network.

Assume that every friendship is mutual. If Fred is Barney’s friend, then Barney is also Fred’s friend.

Input

The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer F, the number of friendships formed, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma
Sample Output

2
3
4

[分析]
就是挺中规中矩的一个并查集。见过这题,请教过大佬,这回做出来了,开心。
[代码]

#include <cstdio>  
#include <map> 
#include <string>  
using namespace std;

map<string, int>mp;
int n, dad[100006], sum[100006];

int getdad(int a)
{
    if (dad[a] == a)
        return a;
    else
    {
        dad[a] = getdad(dad[a]);
        return dad[a];
    }
}

int Merge(int a, int b)
{
    a = getdad(a);
    b = getdad(b);
    if (a!= b)
    {
        dad[a] = b;
        sum[b] += sum[a];
    }
    return sum[b];
}

int main()
{
    int t, n;
    char a[30], b[30];
    while (scanf("%d", &t) != EOF)
    {
        while (t--)
        {
            mp.clear();
            int num = 1;
            scanf("%d", &n);
            for (int i = 1; i<100005; i++)
            {
                dad[i] = i;
                sum[i] = 1;
            }
            for(int i=0;i<n;i++)
            {
                scanf("%s%s", a, b);
                if (!mp[a])mp[a] = num++;
                if (!mp[b])mp[b] = num++;
                printf("%d\n", Merge(mp[a], mp[b]));
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值