hdu 5491 The Next(ICPC合肥赛)

The Next

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 808    Accepted Submission(s): 316


Problem Description
Let  L  denote the number of 1s in integer  D ’s binary representation. Given two integers  S1  and  S2 , we call  D  a WYH number if  S1LS2 .
With a given  D , we would like to find the next WYH number  Y , which is JUST larger than  D . In other words,  Y  is the smallest WYH number among the numbers larger than  D . Please write a program to solve this problem.
 

Input
The first line of input contains a number  T  indicating the number of test cases ( T300000 ).
Each test case consists of three integers  D S1 , and  S2 , as described above. It is guaranteed that  0D<231  and  D  is a WYH number.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the next WYH number.
 

Sample Input
  
  
3 11 2 4 22 3 3 15 2 5
 

Sample Output
  
  
Case #1: 12 Case #2: 25 Case #3: 17
 

Source


题目大意:
就是给定一个数d,让你求二进制数中1的个数>=s1同时<=s2中的数

解题思路:
首先得到这个数二进制中1的个数,然后让这个数+1,判断当d>s2 和<s1的情况,因为找的是最小值,
所以,只需要当<s1的时候将二进制中0的个数变为1
>s1的时候,将二进制中1的个数变为0

上代码:
/**
2015 - 09 - 22 下午


Author: ITAK


Motto:


今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;

#define MM(a) memset(a,0,sizeof(a))

typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 10000+5;
const int mod = 1000000007;
const double eps = 1e-7;

bool arr[35];
LL t;
///得到1的个数
LL get_1(LL x)
{
    LL sum = 0;
    t = 0;
    while(x)
    {
        arr[t++] = x%2;
        if(x&1)
            sum++;
        x>>=1;
    }
    return sum;
}
int main()
{
    LL d, s1, s2, T;
    scanf("%lld",&T);
    for(LL cas=1; cas<=T; cas++)
    {
        scanf("%lld%lld%lld",&d,&s1,&s2);
        MM(arr);
        t = 0;
        d++;
        while(1)
        {
            LL ans = get_1(d);
            if(ans < s1)
            {
                for(int i=0; i<t; i++)
                    if(!arr[i])
                    {
                        d += 1<<i;
                        break;
                    }
            }
            else if(ans > s2)
            {
                for(int i=0; i<t; i++)
                    if(arr[i])
                    {
                        d += 1<<i;
                        break;
                    }
            }
            else
                break;
        }
        printf("Case #%lld: %lld\n",cas,d);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值