HDU 5974 A Simple Math Problem(数学解方程)——2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

227 篇文章 0 订阅
97 篇文章 0 订阅

传送门

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 262    Accepted Submission(s): 120


Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b
 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input
  
  
6 8
798 10780
 

Sample Output
  
  
No Solution
308 490
 

题目大意:

给了两个式子, x+y=aLCM(x,y)=b 输出的是 x,y ,如果不存在输出 No Solution

解题思路:

首先 LCM(x,y) = xyGCD(x,y) = b 又因为 GCD(x,y) = GCD(a,b) 那么现在这个 tmp = GCD(x,y) 就是常数了,那么就变成了 xytmp = b ,又因为 x+y = a 那么就可以得到 x(ax) = btmp 然后转化为 一元二次方程,求最优解。题目保证的是输出的 (x,y),xy

My Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
LL GCD(LL a, LL b){
    if(b == 0)
        return a;
    return GCD(b, a%b);
}
int main()
{
    LL a, b;
    while(~scanf("%lld%lld",&a,&b)){
        LL tmp = GCD(a, b);
        b *= tmp;
        tmp = a*a - 4*b;
        if(tmp < 0)
            puts("No Solution");
        else{
            if((LL)sqrt(tmp)*(LL)sqrt(tmp)!=tmp)
                puts("No Solution");
            else{
                tmp = (LL)sqrt(tmp);
                LL ta1 = (a-tmp)/2, ta2 = a-ta1;
                LL tb1 = (a+tmp)/2, tb2 = a-tb1;
                if((a+tmp) & 1){
                    if((a-tmp) & 1)
                        puts("No Solution");
                    else
                        printf("%lld %lld\n",min(ta1, ta2),max(ta1,ta2));
                }
                else{
                    if((a-tmp) & 1){
                        if(min(tb1,tb2) < 0)
                            puts("No Solution");
                        else
                            printf("%lld %lld\n",min(tb1, tb2),max(tb1,tb2));
                    }
                    else{
                        if(min(tb1,tb2) < 0)
                            printf("%lld %lld\n",min(ta1, ta2),max(ta1,ta2));
                        else{
                            if(min(ta1,ta2) < min(tb1,tb2))
                                printf("%lld %lld\n",min(ta1, ta2),max(ta1,ta2));
                            else
                                printf("%lld %lld\n",min(tb1, tb2),max(tb1,tb2));
                        }
                    }
                }
            }
        }
    }
    return 0;
}
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值