HDU-1005-Number Sequence(Java版+考虑周期+恶心水题!)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 122527    Accepted Submission(s): 29758


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1021  1019  1003  1009 


有时候会怀疑出这种题目的作者是不是脑子有问题?只有20%的通过率,12万多的acmer提交只有3万不到的通过率!
你想题目一定是很难吧,其实不是,题目是很坑! (1 <= A, B <= 1000, 1 <= n <= 100,000,000)
里面n的取值范围是一个亿,如果直接递归来代入的话!肯定堆栈溢出.....(因为我试过!)
最后在网上查了一下思路: 因为f(n)的结果是模7的,那么f(n)的结果只可能在{0,1,2,3,4,5,6,}中,这样f(n)与f(n-1)的结果只可能是7*7 = 49种,合理利用周期性,便可以大大提高程序运行时间。

不想说了,这题多说一句话都make me sick!!
感谢金永庆博友的解答!

import java.io.*;
import java.util.*;

public class Main
{  
    public static void main(String[] args) 
    {  
        Scanner input = new Scanner(System.in);  
        int a, b;  
        int n;  
        while (input.hasNext()) 
        {  
            a = input.nextInt();  
            b = input.nextInt();  
            n = input.nextInt();  
            if (a == 0 & b == 0 & n == 0)  
                System.exit(0);  
            int f[] = new int[50];  
            for (int i = 1; i < 50; i++) 
            {  
                if (i == 1 || i == 2) 
                {  
                    f[i] = 1;  
                } else 
                {  
                    f[i] = (a * f[i - 1] + b * f[i - 2]) % 7;  
                }  
            }  
            System.out.println(f[n % 49]);  
        }  
    }  
  
}  




 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值