PAT 1015. Reversible Primes (20)(d进制转化,质数判定(注意等于号))

题目

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

解题思路

  • 1.是将这个数在d进制下反转,然后转化为十进制数,再判断它们俩是不是质数(题目有点烦),注意0,1不是质数。

AC代码

#include<iostream>
#include<deque>
#include<math.h>
using namespace std;
bool isPrim(int num){
    if (num == 1) {
        return false;
    }
    //!!!!注意有个等于号
    for (int i = 2; i <= sqrt(num); ++i) {
        if (num % i ==0) {
            return false;
        }
    }
    return true;
}

int main(int argc, char *argv[])
{
    int n;
    int tem_n;
    while (cin>>n) {
        tem_n = n;
        if (n<0) {
            return 0;
        }
        int d;
        cin >> d;
        deque<int> dq;
        while (n>0) {
            dq.push_back(n % d);
            n = n / d;
        }
        int reverse = 0,tp,i =0;
        while (!dq.empty()) {
            tp = dq.back();
            reverse += pow(d,i) * tp;
            i++;
            dq.pop_back();
        }

       // cout << reverse << endl;
        if (isPrim(reverse)&&isPrim(tem_n)) {
            cout << "Yes" <<endl;
        }else {
            cout << "No" << endl;
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值