Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView

转载 2017年01月03日 11:23:25

Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView

Solve call requires api level android programming project error.

Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView

The error ” Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView  ” comes most of android projects at the starting time. Android IDE shows this error because developers are using ” android.support.v7.app.ActionBarActivity ” jar file into android project and this activity file requires minimum api andorid level is api 11. Because ActionBarActivity file have some of features that cannot works properly on minimum android version mobile phone so this application is no use for older mobile phones. Setting up minimum api level restrictions on application’s AndroidManifest.xml file will display a error message before installing this app in older api version mobile phones that ” This application dose not support older android versions from api level 11.” So here is the complete step by step tutorial for Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView .

Solution of Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView error in eclipse.

1. Navigate your projects AndroidManifest.xml file.

AndroidManifest-xml file

2. Open AndroidManifest.xml file.

open file in eclipse

3. Find  android:minSdkVersion=”8″ & replace 8 with 11.Like i do in below code.

 android:minSdkVersion=”11″

4. Save the file and your error will be solved automatically after these changes.

相关文章推荐

Android Call requires API level 11 (current min is 8)的解决方案

*【错误描述】 -在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码, 代码根据系统版本不同执行相应模块,结果,等我输完...

Call requires API level 11 (current min is 8)

【错误描述】在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码,代码根据系统版本不同执行相应模块,结果,等我输完代码,发...

UncaughtException 和 Using 1.7 requires compiling with Android 4.4 (KitKat); currently using API 8

08-04 10:54:04.545: W/dalvikvm(10012): threadid=1: calling UncaughtExceptionHandler 08-04 10:54:04.5...

关于LGame中的call to OpenGL ES API with no current context

那个,今天小弟在一位网友的邮件中,发现有另外一位网友遇到了LGame运行时log中显示call to OpenGL ES API with no current context的问题,估计这个问题挺有...

Android API Level在11前后及16之后时Notification的不同用法

作为刚入门Android的小白,最近在按照郭大神的《第一行代码》在练习,在用到Notification时遇到了一些问题,网上资料比较零散,我这里做了一个总结分析给各位,若有错误,恳请指正~ Notif...

call to OpenGL ES API with no current context (logged once per thread)

背景 cocos2dx Android 工程接入移动基地的短信扣费SDK; 程序运行,扣费成功后 程序崩溃。 eclipse logcat 提示: 网上搜索到两个方法 第...

requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools Fix Pr

requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools  Fix Pr...

Android requires compiler compliance level 5.0 or 6.0. 出错原因分析、解决方法

开发过程中碰到了一个问题:  Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please u...

Android错误之--Platform MNC is a preview and requires application manifest to set minSdkVersion to 'MNC

Android错误之--Platform MNC is a preview and requires application manifest to set minSdkVersion to 'MNC...

this is android sdk requires android developer Toolkit version 23.0.0 or above解决方法

因为之前没有下载Android源码,然后就去Android Developed上下载了一个Android SDK,安装了一下源码。等我第二天起来打开Eclipse一看,工程报错。关闭工程再重新开Esc...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Call Requires API level 11 (current min is 8) Android.App.Activity#onCreateView
举报原因:
原因补充:

(最多只允许输入30个字)