POJ 3176 DP(简单数塔)

Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15863 Accepted: 10567

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

      7

    3   8

  8   1   0

2   7   4   4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output

Line 1: The largest sum achievable using the traversal rules
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output

30

题意:
数塔从上到下,每下一层只能选和上一个位置左右相邻的位置,问怎么走时经过的路径权重相加最大。
解法:
比较经典的dp了,之前在hdu做了一次。这次做做要是求速度,应该是几分钟就敲完AC了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define F(i,a,b) for(int i = a;i<=b;i++)
#define FI(i,a,b) for(int i = a;i>=b;i--)

int dp[1000];
int G[1000][1000];

using namespace std;

int main()
{
//    freopen("data.in","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF){
        F(i,1,n)
            F(j,1,i)
                scanf("%d",&G[i][j]);
        F(i,1,n)
            dp[i] = G[n][i];

        FI(i,n-1,1)
            F(j,1,i)
                dp[j] = G[i][j] + max(dp[j],dp[j+1]);
        printf("%d\n",dp[1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值