hdu 2433 Travel(枚举删掉的边求取最短路)

Travel

Time Limit: 10000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1872    Accepted Submission(s): 627


Problem Description
      One day, Tom traveled to a country named BGM. BGM is a small country, but there are N (N <= 100) towns in it. Each town products one kind of food, the food will be transported to all the towns. In addition, the trucks will always take the shortest way. There are M (M <= 3000) two-way roads connecting the towns, and the length of the road is 1.
      Let SUM be the total distance of the shortest paths between all pairs of the towns. Please write a program to calculate the new SUM after one of the M roads is destroyed.

 

Input
      The input contains several test cases.
      The first line contains two positive integers N, M. The following M lines each contains two integers u, v, meaning there is a two-way road between town u and v. The roads are numbered from 1 to M according to the order of the input.
      The input will be terminated by EOF.

 

Output
      Output M lines, the i-th line is the new SUM after the i-th road is destroyed. If the towns are not connected after the i-th road is destroyed, please output “INF” in the i-th line.
 

Sample Input
  
  
5 4 5 1 1 3 3 2 5 4 2 2 1 2 1 2
 

Sample Output
  
  
INF INF INF INF 2 2
 

Source
题目分析:
记录以某一个点为源点的最短路的生成树中的边,然后每次删掉边,判断这条边是否在这个生成树中,如果在重新求取最短路,如果不在,那么当前的最短路生成树没有变化
 
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#define INF (0x3f3f3f3f)
#define N 107

using namespace std;

int n,m;
int mp[N][N];
int pre[N][N];
int dis[N];
bool vis[N];
int sum[N];

struct Edge
{
    int u,v;
}e[30*N];

int spfa ( int s , int f )
{
    memset ( vis , 0 , sizeof ( vis ) );
    memset ( dis, 0 , sizeof ( dis ) );
    queue<int> q;
    q.push ( s );
    vis[s] = 1;
    while ( !q.empty() )
    {
        int u = q.front();
        q.pop();
        for ( int i = 1 ; i <= n ; i++ )
            if ( mp[u][i] && !vis[i] )
            {
                dis[i] = dis[u] + 1;
                vis[i] = 1;
                if ( f ) pre[s][i] = u;
                q.push ( i );
            }
    }
    int sum = 0;
    for ( int i = 1 ; i <= n ; i++ )
        if ( !dis[i]&& i != s ) return INF;
        else sum += dis[i];
    return sum;
}

int main ( )
{
    while ( ~scanf ( "%d%d" , &n , &m ) )
    {
        int u , v;
        memset ( mp , 0 , sizeof ( mp ) );
        memset ( pre , 0 , sizeof ( pre ) );
        for ( int i = 0 ; i < m ; i++ )
        {
            scanf ( "%d%d" , &u , &v );
            e[i].u = u;
            e[i].v = v;
            mp[u][v]++;
            mp[v][u]++;
        }
        int temp = 0;
        bool flag = 1;
        for ( int i = 1 ; i <= n ; i++ )
        {
            sum[i] = spfa ( i , 1 );
            temp += sum[i];
            if ( temp >= INF )
            {
                flag = 0;
                break;
            }
        }
        for ( int i = 0 ; i < m ; i++ )
        {
            int ans = 0;
            u = e[i].u , v = e[i].v;
            if ( flag && mp[u][v] == 1 )
            {
                ans = 0;
                for ( int j = 1 ; j <= n ; j++ )
                {
                    if ( pre[j][u] != v && pre[j][v] != u )
                        ans += sum[j];
                    else
                    {
                        mp[u][v]--;
                        mp[v][u]--;
                        ans += spfa ( j , 0 );
                        mp[u][v]++;
                        mp[v][u]++;
                        if ( ans >= INF )
                            break;
                    }
                }
            }
            else ans = temp;
            if ( ans >= INF ) puts ( "INF" );
            else printf ( "%d\n" , ans );
        } 
    }
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值