poj1284(欧拉函数、原根)

Primitive Roots
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4639 Accepted: 2744

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

题意:给出一个素数,求出它的原根个数。

原根定义:设m是正整数,a是整数,若a模m的阶等于φ(m),则称a为模m的一个原根。(即a^k=1(mod m)的最小k是m的欧拉函数时,a为mde一个原根)

假设一个数g对于P来说是原根,那么g^i mod P的结果两两不同,且有 1<g<P, 0<i<P,那么g可以称为是P的一个原根,归根到底就是g^(P-1) = 1 (mod P)当且仅当指数为P-1的时

定理1:如果p有原根,则它恰有φ(φ(p))个不同的原根(无论p是否为素数都适用)
p为素数,当然φ(p)=p-1,因此就有φ(p-1)个原根候成立.(这里P是素数).


#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
#define size 65636

int euler[size];

void Init()

{

     memset(euler,0,sizeof(euler));

          euler[1]=1;

     for(int i=2;i<size;i++)

       if(!euler[i])

       for(int j=i;j<size;j+=i)

       {

              if(!euler[j])

               euler[j]=j;

               euler[j]=euler[j]/i*(i-1);//先进行除法是为了防止中间数据的溢出

         }

}
int main()
{
	Init();
	int p;
	while(~scanf("%d",&p))
	{
		printf("%d\n",euler[p-1]);
	}
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值