poj1284

Primitive Roots

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

Source


求原根的个数。当p有原根时,它有φ(φ(p))个原根。此题中p为奇素数,所以φ(p)=p-1,φ(φ(p))=φ(p-1),问题转化为求欧拉函数。
代码如下:
#include<stdio.h>

int euler_phi(int p) {
    int phi = p;
    for (int i = 2; i * i <= p; i++) {
        if (!(p % i)) {
            phi = phi - phi / i;
            while (!(p % i))
                p /= i;
        }
    }
    if (p > 1)
        phi = phi - phi / p;
    return phi;
}

int main(void) {
    int p;
    while (scanf("%d", &p) != EOF) {
        printf("%d\n", euler_phi(p - 1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值