HDU 1342 Lotto

Lotto

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1727    Accepted Submission(s): 848


Problem Description
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k. 
 

Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case. 
 

Sample Input
  
  
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
 

Sample Output
  
  
1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34
 
AC代码:

第一种写法: 15ms
两重DFS 表该数选或者不选
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int N;
int a[20];
int b[10];
void DFS(int num, int pos)
{
    if(num == 7)
    {
        for(int i = 1; i <= 6; i++)
        {
            if(i > 1) printf(" ");
            printf("%d", b[i]);
        }
        printf("\n");
        return ;
    }
    if(pos > N) return ;
    b[num] = a[pos];
    DFS(num+1, pos+1);//选
    DFS(num, pos+1);//不选
}
int main()
{
    int t = 0;
    while(scanf("%d", &N), N)
    {
        if(t > 0) printf("\n");
        for(int i = 1; i <= N; i++)
            scanf("%d", &a[i]);
        DFS(1, 1);
        t++;
    }
    return 0;
}



第二种写法: 0ms
回溯 表选择 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int N;
int a[20];
int b[10];
void DFS(int num, int pos)
{
    if(num == 7)
    {
        for(int i = 1; i <= 6; i++)
        {
            if(i > 1) printf(" ");
            printf("%d", b[i]);
        }
        printf("\n");
        return ;
    }
    if(pos > N) return ;
    b[num] = a[pos];
    num++;
    DFS(num, pos + 1);
    num--;
    DFS(num, pos + 1);
}
int main()
{
    int t = 0;
    while(scanf("%d", &N), N)
    {
        if(t > 0) printf("\n");
        for(int i = 1; i <= N; i++)
            scanf("%d", &a[i]);
        DFS(1, 1);
        t++;
    }
    return 0;
}


第三种写法:31ms

数组标记 回溯
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int N;
int a[20];
int b[10];
bool used[20];
void DFS(int num, int pos)
{
    if(num == 7)
    {
        for(int i = 1; i <= 6; i++)
        {
            if(i > 1) printf(" ");
            printf("%d", b[i]);
        }
        printf("\n");
        return ;
    }
    else
    {
        for(int i = pos; i <= N; i++)
        {
            if(used[i]) continue;
            used[i] = true;
            b[num] = a[i];
            DFS(num+1, i+1);
            used[i] = false;
        }
    }
}
int main()
{
    int t = 0;
    while(scanf("%d", &N), N)
    {
        if(t > 0) printf("\n");
        for(int i = 1; i <= N; i++)
            scanf("%d", &a[i]);
        memset(used, false, sizeof(used));
        DFS(1, 1);
        t++;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值