POJ 2376 - Cleaning Shifts(最小区间覆盖)

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17736 Accepted: 4516

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

题意:有个区间,选择尽量少的区间,使得这些区间完全覆盖某线段。

算法:将所有区间按左端点坐标从小到大排序,顺序处理每个区间。每次选择覆盖点的区间中右端点坐标最大的一个,并将更新为该区间的右端点坐标,直到选择的区间已包含。注意(1,2 )和(3,4)可以覆盖(1,4)。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

struct Node
{
	int x,y;
}node[25005];

bool cmp(Node a,Node b){
	if(a.x == b.x)	return a.y < b.y;
	return a.x < b.x;
}
int main()
{
	ios_base::sync_with_stdio(0);
	cin.tie(0);

	int n,t;
	while(cin>>n>>t){
		int right = 1;
		for(int i = 1;i <= n;i ++){
			cin>>node[i].x>>node[i].y;
			right = max(node[i].y,right);
		}

		sort(node+1,node+n+1,cmp);
		node[n+1].x = 0x3f3f3f;
		
		if(node[1].x > 1 || right < t){
			cout<<-1<<endl;
			continue;
		}

		int s = 0,ans = 0;
		int flag = 0,maxn = 1;;
		for(int i = 1;i <= n;i ++){
			if(node[i].x <= s+1){
				if(node[i].y > s){
					maxn = max(maxn,node[i].y);
					flag = 1;	
				}
				if(node[i+1].x > s+1 && flag){
					ans++;
					s = maxn;
					flag = 0;
				}
			}
		}
		if(s < t)	cout<<-1<<endl;
		else
			cout<<ans<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值