POJ - 3186【dp】

                                                                                                                                         Treats for the Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5507 Accepted: 2871

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43


题意:

有一个长度为n的盒子里面装有不同价值的饼干,奶牛每次可以从左边或者右边拿饼干。ans = ∑ val[i] * (第几次拿的);求ans最大值;

题解:

很容易想到dp方程。设dp[i][j] 为 i-j 这一段的最大价值。。。dp[i][j] = max(dp[i+1][j] + val[i] * len, dp[i][j-1] + val[j]  * len);其中len为第几次拿,len = n-(j-i);但是呢,转移方向需要考虑一下,注意到 i 是从右向左转移的,j 是从左向右转移的。那么dp的转移方向就应该是反向的。初始化所有的 dp[i][i] = val[i];

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <bitset>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <list>
#include <set>
#include <map>
#define rep(i,a,b) for(int i = a;i <= b;++ i)
#define per(i,a,b) for(int i = a;i >= b;-- i)
#define mem(a,b) memset((a),(b),sizeof((a)))
#define FIN freopen("in.txt","r",stdin)
#define FOUT freopen("out.txt","w",stdout)
#define IO ios_base::sync_with_stdio(0),cin.tie(0)
#define mid ((l+r)>>1)
#define ls (id<<1)
#define rs ((id<<1)|1)
#define N 2005
#define INF 0x3f3f3f3f
#define INFF ((1LL<<62)-1)
typedef long long LL;
using namespace std;

int n, a[N], dp[N][N];
int main()
{IO;
	//FIN;
	while(cin >> n){
		mem(dp, 0);
		rep(i, 1, n){
			cin >> a[i];
			dp[i][i] = a[i];
		}
		per(i, n, 1){
			rep(j, i, n)
				dp[i][j] = max(dp[i+1][j]+a[i]*(n-(j-i)), dp[i][j-1]+a[j]*(n-(j-i)));
		}
		cout << dp[1][n] << endl;
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值