Codeforces 890 C. Petya and Catacombs (贪心)

Description

A very brave explorer Petya once decided to explore Paris catacombs. Since Petya is not really experienced, his exploration is just walking through the catacombs.

Catacombs consist of several rooms and bidirectional passages between some pairs of them. Some passages can connect a room to itself and since the passages are built on different depths they do not intersect each other. Every minute Petya arbitrary chooses a passage from the room he is currently in and then reaches the room on the other end of the passage in exactly one minute. When he enters a room at minute i, he makes a note in his logbook with number ti:

If Petya has visited this room before, he writes down the minute he was in this room last time;

Otherwise, Petya writes down an arbitrary non-negative integer strictly less than current minute i.

Initially, Petya was in one of the rooms at minute 0, he didn’t write down number t0.

At some point during his wandering Petya got tired, threw out his logbook and went home. Vasya found his logbook and now he is curious: what is the minimum possible number of rooms in Paris catacombs according to Petya’s logbook?

 

Input

The first line contains a single integer n (1 ≤ n ≤ 2·10^5) — then number of notes in Petya’s logbook.

The second line contains n non-negative integers t1, t2, …, tn (0 ≤ ti < i) — notes in the logbook.

 

Output

In the only line print a single integer — the minimum possible number of rooms in Paris catacombs.

 

Examples input

2
0 0

 

Examples output

2

 

题意

每到达一个房间,有两种标号的记法:

  1. 记录上一次到达该房间的时间
  2. 随机一个小于当前时间的数字

问最少有几个房间。

 

思路

显然房间数目越少要求我们经过同一个房间的次数尽可能的多,于是对于每一个编号,我们假设它记录的是上一次到达该房间的时间,判断假设是否成立,若成立,更新该房间的最后抵达时间,否则房间数加一。

 

AC 代码

#include<bits/stdc++.h>
#define IO ios::sync_with_stdio(false);\
    cin.tie(0);\
    cout.tie(0);
typedef long long LL;
using namespace std;
const int maxn = 2e6+10;

int last[maxn];
int a[maxn];
int num[maxn];
int n;

void solve()
{
    int ans = 1;
    for(int i=1; i<=n; i++)
    {
        int now = a[i];
        if(last[num[now]]==a[i])
        {
            last[num[now]]=i;
            num[i] = num[now];
        }
        else
        {
            num[i]=++ans;
            last[num[i]]=i;
        }
    }
    cout<<ans<<endl;
}

int main()
{
    IO;
    cin>>n;
    for(int i=1; i<=n; i++)
        cin>>a[i];
    solve();
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值