第六届福建省大学生程序设计竞赛 Problem J RunningMan【数学】

Problem J RunningMan

 

Accept: 123    Submit: 551

Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

Sample Input

2

100 100

200 100

Sample Output

No

Yes

Hint

In the second example, the RunningMan team can arrange 60, 60, 80 people for the three rounds. No matter how the opposite team arrange their 100 people, they cannot win.

解题思路:

几组数据可以得出,只要其中的最少的两组的人数大于另外一队则可以输出Yes。

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		int LL;
		int LLL;
		LLL=a%3;
		LL=a/3;
		if(LLL==0)
		{
			if(2*(LL+1)>b)
			{
				printf("Yes\n");
			}
			else
			{
				printf("No\n");
			}
		}
		else if(LLL==1)
		{
			if(2*(LL+1)>b)
			{
				printf("Yes\n");
			}
			else
			{
				printf("No\n");
			}
		}
		else if(LLL==2)
		{
			if(2*(LL+1)+1>b)
			{
				printf("Yes\n");
			}
			else
			{
				printf("No\n");
			}
		}
	}
	return 0;
} 

 

 

《HTT电脑秘书软件》是一个小巧实用的工具,通过它可以方便地打开您常用的程序、文档资料、以及网站链接等。《HTT电脑秘书软件》 的最大好处,莫过于它的易用性。当然,它还有许多特点: 1、极其简单的打开/隐藏方式:鼠标移向屏幕右下角,《HTT电脑秘书软件》 主窗口马上打开;鼠标移向屏幕右边界下方,主窗口立即消失,移到右边界上方,主窗口立即显示。也可以通过单击右下角的本系统图标进行打开和隐藏。 2、允许对程序项进行分门别类,用户可建立任意树形目录结构,并提供两种目录显示方式。 3、可以对《HTT电脑秘书软件》中的任何程序文档等项目定义系统级热键,无论《HTT电脑秘书软件》是否在前台,均可捕获热键。 4、有自启动功能,每次进入Windows后,《HTT电脑秘书软件》 以小图标方式显示在任务条上的通知区中。 5、支持OLE拖放功能,您可将任意文件或IE/Netscape中的超链接拖入《HTT电脑秘书软件》中。 6、提供多种小巧实用的工具,如日程记事、HTT文档编辑器,HTT图片编辑器、Office文档编辑器等,并允许以插件方式加以扩充。 7、可以通过拖放方式,将你的系统中的所有文件添加到【文档库】节点(该节点对应本系统所在路径下的文件夹),将你系统的所有文件进行集中管理。 《HTT电脑秘书软件》 的插件编程接口: 如果你需要给本系统编写插件,请与我们公司联系。 E-mail: htt@huitetong.com WWW: http://www.huitetong.com Tel: 010-82896850 13801355031 作者:赵宝泽
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值