解题报告:HDU 2196 Computer 简单树型DP

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6360    Accepted Submission(s): 3202


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 

Author
scnu
 

Recommend
lcy
 

Statistic |  Submit |  Discuss | Note

题意:
给定一棵树,求树上所有点的最远点距
思路:
离一个点的最远的点要不是它的子树的叶子,要不就是先往上到它的某个祖先,然后再走另外的某个子树到叶子
在子树的最远距离很好求,一遍dfs就能解决
往上的最远距离从根往下递归 每层就只用考虑当前点到父亲节点的距离+父亲节点到兄弟的距离+兄弟在子树的最远距离
dp[i][0]表示节点i往下的最远距离,dp[i][1]表示节点i往上的最远距离
第一遍dfs: dp[i][0] = max(W[k] + dp[k][0] )        k 为 i 的儿子   , W[k]为k到k的父亲之间的距离。
第二遍dfs: dp[i][1] = max(dp[fa][1] , dp[j][0]+W[i]+W[j] )       fa 为 i 的父亲 , j 为 i 的兄弟

最后依次输出max(dp[i][0],dp[i][1])即可
思路就是这样,写法比较随意


代码:
#include<bits/stdc++.h>

using namespace std;

struct edge{
    int t,w;
    edge(){};
    edge(int _t,int _w){
        t = _t ;
        w = _w;
    }
};

int n;
int dp[10005][2];
vector<edge>G[10005];


void dfs1(int x){
    dp[x][0]=0;
    for(int i=0;i<G[x].size();i++){
        edge &j = G[x][i];
        dfs1(j.t);
        dp[x][0] = max(dp[x][0],dp[j.t][0]+j.w);
    }return ;
}

void dfs2(int x,int fa=0){
    dp[x][1]=dp[fa][1];
    int w = 0;
    for(int i=0;i<G[fa].size();i++){
        edge &j = G[fa][i];
        if(j.t!=x){
            dp[x][1] = max(dp[x][1],dp[j.t][0]+j.w);
        }else {
            w = j.w;
        }
    }dp[x][1] += w;
    for(int i=0;i<G[x].size();i++){
        dfs2(G[x][i].t,x);
    }return ;
}

int main()
{
    while(scanf("%d",&n)==1){
        for(int i=1;i<=n;i++){
            G[i].clear();
        }
        for(int i=2,f,w;i<=n;i++){
            scanf("%d%d",&f,&w);
            G[f].push_back(edge(i,w));
        }dfs1(1);dfs2(1);
        for(int i=1;i<=n;i++){
            printf("%d\n",max(dp[i][0],dp[i][1]));
        }
    }return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值