HDU-1241-Oil Deposits(BFS)

J - Oil Deposits
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 1241
Appoint description:
Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

题意:@代表油井,横纵斜八个方向都算是相邻,问有多少片油井是独立存在的。
思路:遍历图,遇到@就把它八个方向的油井都标记,然后入队循环,直至队列为空,这时独立数量++即可

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h>
using namespace std;
const int maxn=105;
char map[maxn][maxn];//存图
int dis[8][2]= {{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}}; //八个搜素方向
int M;//M行
int N;//N列
int num;//已找到油田片的数量
struct node
{
    int x;
    int y;
};
bool Judge(int x,int y)
{
    if(x>=0&&x<M&&y>=0&&y<N&&map[x][y]=='@')
        return true;
    return false;
}
void BFS()
{
    num=0;//初始化油田连片数量
    for(int i=0; i<M; i++)
    {
        for(int j=0; j<N; j++)
        {
            if(map[i][j]=='@')//遍历图找到油井
            {
                queue<node>q;
                node star;
                star.x=i;
                star.y=j;
                q.push(star);
                while(!q.empty())
                {
                    star=q.front();
                    q.pop();
                    for(int i=0; i<8; i++) //八个搜索方向
                    {
                        node end=star;
                        end.x+=dis[i][0];
                        end.y+=dis[i][1];
                        if(Judge(end.x,end.y))//和它相连的油井全部设置为*
                        {
                            map[end.x][end.y]='*';
                            q.push(end);
                        }
                    }
                }
                num++;
            }
        }
    }
    printf("%d\n",num);
}
void init()
{
    for(int i=0; i<M; i++)
        for(int j=0; j<N; j++)
           cin>>map[i][j];
}
int main()
{
    while(~scanf("%d%d",&M,&N))
    {
        if(N==0&&M==0)
            break;
        init();
        BFS();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值