ZOJ-1586-QS Network(最小生成树 普利姆)

E - QS Network
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

ZOJ 1586
Description
Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS’s have received the message.

A sample is shown below:

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS’s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input
The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS’s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output
for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input
1
3
10 20 30
0 100 200
100 0 300
200 300 0

Sample Output
370

题意:第一行给出T,代表有T组数据。每组数据第一行给出N,代表图有N个结点。接着一行给出N个数,代表每个结点的权值(就是接收器的费用),接着N行每行N个数,矩阵的形式给出各点之间边的权值(也就是连接接收器网线的费用)。最后实际权值就是边的权值加上两个点的权值,输出最小生成树的权值总和即可。

裸的普利姆算法

代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1005;
const int INF=0x3f3f3f3f;
int map[maxn][maxn];//边的权值
int vis[maxn];
int dis[maxn];
int num[maxn];//点的权值
int T;//数据组数
int N;//图的结点数量
void init()
{
    scanf("%d",&N);//图结点的数量
    for(int i=1; i<=N; i++) //点的权值
        scanf("%d",&num[i]);
    for(int i=1; i<=N; i++)
        for(int j=1; j<=N; j++)
        {
            scanf("%d",&map[i][j]);
            map[i][j]+=num[i]+num[j];
        }
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    for(int i=1; i<=N; i++)
        dis[i]=map[i][1];
}
void Prim()
{
    int min_dis=0;//最小生成树的权值
    for(int i=1; i<N; i++)
    {
        int minn=INF;
        int point_minn;
        for(int j=1; j<=N; j++)
            if(vis[j]==0&&minn>dis[j])
            {
                minn=dis[j];
                point_minn=j;
            }
        if(minn==INF)
            break;
        min_dis+=dis[point_minn];
        vis[point_minn]=1;
        for(int k=1; k<=N; k++)
            if(vis[k]==0&&dis[k]>map[point_minn][k])
                dis[k]=map[point_minn][k];
    }
    printf("%d\n",min_dis);
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        init();
        Prim();
    }
    return 0;
}

慢慢就有自己的代码风格了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值