Climbing Worm(贪心)

C - Climbing Worm
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input
10 2 1
20 3 1
0 0 0

Sample Output
17
19

题意:多组数据,每组数据给出N U D。有条一英寸长的虫子,初始时在N英寸深的井中,它可以用一分钟爬U英寸,但想再次爬行就必须先休息一分钟,这期间它会下落D英寸,输出多久虫子的头部可以超过井口或者和井口平齐。

思路:模拟题意,以头部的坐标为准,达到条件结束循环并输出即可

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
int main()
{
    int N,U,D;
    while(~scanf("%d%d%d",&N,&U,&D)&&N&&U&&D)
    {
        int sum=0;
        int point=0;//虫子头部初始位置
        while(point<N)
        {
            if(point+U<N)
            {
                point+=U-D;
                sum+=2;
            }
            else
            {
                point+=U;
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值