HDU-1081-To The Max(二维最大子段和)

To The Max

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11800 Accepted Submission(s): 5702

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output
15

题意:给出N*N的矩阵,求出最大子矩阵和

思路:对于长度为N的一维字段,很容易求出他的最大子段和,对于二维的,我们可以把每一行都累加,就可以枚举出所有行的组合。
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
处理后应该是
0 -2 -7 0
9 0 -13 2
5 1 -17 3
4 9 -17 1
想枚举原矩阵的第2,3,4行,只需要用处理后矩阵的第4行减去第1行即可,接着求一维最大子段和就就不用讲了吧。。

这题没有NYOJ-104坑,我没有把结果初始化为负无穷居然也能过。。

代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
//二维最大字段和
const int maxn=105;
int num[maxn][maxn];
int main()
{
    int N;
    while(~scanf("%d",&N))
    {
        memset(num[0],0,sizeof(num[0]));//只把第一行清零就可以
        for(int i=1; i<=N; i++)
        {
            for(int j=1; j<=N; j++)
            {
                int flag;
                scanf("%d",&flag);
                num[i][j]=num[i-1][j]+flag;
            }
        }
        int result=0;
        for(int i=0; i<=N; i++)
        {
            for(int j=i+1; j<=N; j++)
            {
                int flag[maxn];//j-i=i,i+1,i+2,j的和
                memset(flag,0,sizeof(flag));
                for(int k=1; k<=N; k++)
                    flag[k]=num[j][k]-num[i][k];

                int DP[maxn];
                memset(DP,0,sizeof(DP));
                for(int k=1; k<=N; k++)
                {
                    DP[k]=max(DP[k-1]+flag[k],flag[k]);
                    result=max(result,DP[k]);
                }
            }
        }
        printf("%d\n",result);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值