HDU 2608 0 or 1(数学推导)

109 篇文章 0 订阅
39 篇文章 0 订阅

0 or 1

Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3273 Accepted Submission(s): 914

Problem Description
Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).

Input
The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.

Output
For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .

Sample Input
3
1
2
3

Sample Output
1
0
0

Hint
Hint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8
S(3) % 2 = 0

+++++++++++++++++++++++++++++++++++++++
本题是一道比较难的数学推导题目,其实想到了也就那样。
(一).假如一个数n是一个奇数。
1.假如n不是某个数的平方,那么T(n)一定为0,因为出现了有限对因子。
2.假如n是某个数的平方的话,那么T(n)一定为1,此时i*i=n,那么在有限对因子后多出了一个因子i,所以T(n)为1.
(二).假如一个数n是一个偶数。
那么这个数一定可以写成2乘以一个奇数的形式,假如2 * i *i=n的话此时T(n)为1,至于分析方式与奇数一样 。
请大家仔细看分析过程,看不懂的话可以打表找下规律。
如有好的见解请留言。

+++++++++++++++++++++++++++++++++++++

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int sum=0;
        for(int i=1; i<=n; i++)
        {
            if(i*i<=n)
                sum++;
            if(2*i*i<=n)
                sum++;
            if(i*i>n)
            {
                break;
            }
        }
        printf("%d\n",sum%2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值