UVA 10305 Ordering Tasks(拓扑排序入门)【刘汝佳算法入门经典例6-15】

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

题意:有n个任务,每个任务与 其他任务有对应的小于关系,给出了m个关系,让你对这些任务进行排序,输出其中的一个序列。
现在没有字典序的要求,我们只需对其进行dfs就好了。
下面试AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int MAXN=200;
int n,m,map[MAXN][MAXN];
int c[MAXN];
int topo[MAXN],t;


bool dfs(int u)
{
   c[u]=-1;//访问标志
   for(int v=1;v<=n;v++)
   {
      if(map[u][v])
      {
         if(c[v]<0)//判断是否为有向环
         {
            return false ;
         }
         else if (!c[v])
         {
         dfs(v) ;
         }
       }
    }
    c[u] = 1 ;
    topo[--t] = u ;//至于这里为什么这样子写,大家可以思考一下
    return true ;
}


bool toposort()
{
    t=n;
    memset(c,0,sizeof(c));
    for(int i=1;i<=n;i++)
    {
       if(!c[i])
       {
           if(!dfs(i))
           {
            return false ;
           }
       }
     }
    return true ;
}


int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0) break;
        memset(map,0,sizeof(map));
        memset(topo,0,sizeof(topo));
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            map[u][v]=1;
        }
        toposort();
        for(int i=0;i<=n-2;i++)
        printf("%d ",topo[i]);
        printf("%d\n",topo[n-1]);
    }
    return 0;
}

下面是另外一种做法,不过下面这种做法输出的结果是按着字典序从小到大的要求。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int n,m,vis[1005],e[1005][1005];

bool judge(int k)//判断还有没有比k更小的
{
    for(int i=1; i<=n; i++)
        if(e[k][i])
        {
            return 0;
        }
    return 1;
}

bool clea(int k)//输出k以后,比k小的关系就不需要管了
{
    for(int i=1; i<=n; i++)
    {
        e[i][k]=0;
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(e,0,sizeof(e));
        int x,y;
        memset(vis,0,sizeof(vis));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            e[y][x]=1;
        }
        int cnt=0;
        while(cnt<n)
        {
            for(int i=1; i<=n; i++)
            {
                if(vis[i])
                    continue;
                if(judge(i))
                {
                    if(cnt)
                        printf(" ");
                    printf("%d",i);
                    vis[i]=1;
                    cnt++;
                    clea(i);
                    break;
                }
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值