HDU 3555 Bomb(数位DP)

37 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3555

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 16312 Accepted Submission(s): 5961

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,”149”,”249”,”349”,”449”,”490”,”491”,”492”,”493”,”494”,”495”,”496”,”497”,”498”,”499”,
so the answer is 15.

Author
fatboy_cw@WHU

Source
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

【中文题意】问你从0到n这个范围内包含49的数有多少个,具体点的规则看题目。
【思路分析】典型的数位DP题目,具体详解都在AC代码中,一些基础的定义以及某些含义我在不要62这个题目中写过,在此不再赘述,不要62的链接:http://blog.csdn.net/qq_32866009/article/details/53047478
【AC代码】

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define LL long long

LL dp[20][12],dight[20];

LL dfs(LL pos,LL pre,LL limit)
{
    if(pos==-1)
    {
        return 0;
    }
    if(!limit&&dp[pos][pre]!=-1)
    {
        return dp[pos][pre];
    }
    LL re=0;
    LL tmp=limit?dight[pos]:9;
    for(LL i=0;i<=tmp;i++)
    {
        if(pre==4&&i==9&&!limit)//判断是不是到了最后一位
        {
            re+=(LL)pow(10,pos);
        }
        else if(pre==4&&i==9&&limit)//到了最后一位的情况
        {
            for(LL j=pos-1;j>=0;j--)
            {
                re+=dight[j]*(LL)pow(10,j);
            }
            re++;
        }
        else
        {
            re+=dfs(pos-1,i,limit&&i==tmp);
        }
    }
    if(!limit)
    {
        dp[pos][pre]=re;
    }
    return re;
}

LL cal(LL n)
{
    LL len=0;
    while(n)
    {
        dight[len++]=n%10;
        n/=10;
    }
    return dfs(len-1,0,1);
}

int main()
{
    memset(dp,-1,sizeof(dp));
    int t;
    scanf("%d",&t);
    while(t--)
    {
        LL n;
        scanf("%I64d",&n);
        printf("%I64d\n",cal(n));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值