POJ 3069

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

  1. 题意:英语伤不起=-=, 大概就是 给出一个n 一个 r n是一条直线上面有n个点 的坐标(相当于数轴) 在这些点上面放一个灯 给出的r 就是灯的照射范围,让你求出 最少给出多少个灯才能把一条线照满
  2. 思路: 按照贪心的思路,充分的利用r到每个点的区间

import java.util.Arrays;
import java.util.Scanner;


public class Main {
    private static int n ,r,current=0;
    private static int[] array;
    public static void main(String[] args) {
    Scanner scanner = new Scanner(System.in);
    while (scanner.hasNext()) {
        current =0;
        r = scanner.nextInt();
        n = scanner.nextInt();
        if (n==-1&&r==-1) 
        break;
        array = new int[n];
        for (int i = 0; i < array.length; i++) {
        array[i] = scanner.nextInt();
        }
        int i=0;
        Arrays.sort(array);//先对这n个点排序
        while (i<n) {
        int x = array[i++];
        while (i<n&&x+r>=array[i]) //相当于第一个点加上r(照射范围)大于下一个点,这样下一个点就不用放灯了,直接i++,知道不能照到为止
            i++;
        int  p = array[i-1];
        while (i<n&&p+r>=array[i]) //这就是下一个点了  同理以上
            i++;
        current ++;
        }
        System.out.println(current);

    }
    scanner.close();
    }

}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值