HDU 2689 Sort it [树状数组]【数据结构】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2689
————————————————————————————-.
Sort it

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4140 Accepted Submission(s): 2945

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output
For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input
3
1 2 3
4
4 3 2 1

Sample Output
0
6

Author
WhereIsHeroFrom

Source
ZJFC 2009-3 Programming Contest

————————————————————————————-.

题目大意:
就是问这个序列冒泡排序的话 需要交换多少次

解题思路:
明确题意之后就非常好理解了
对于每个数字来说交换了多少次 也就是在这个数出现之前有几个比他大的数字。累加即可。

这里维护一个树状数组,每次把a[i]的值更新为1,这样的话查询的时候1~a[i]的和就是这个数出现之前比他大的数字的个数。

处理不难 。

附本题代码
———————————-.

#include <bits/stdc++.h>

#define abs(x)  (((x)>0)?(x):-(x))
#define lalal   puts("*********")
using namespace std;
/**************************************/
const int N = 1000+5;
#define lowbit(x) (x&-x)
int cnt,sum[N],a[N];
void update(int index,int val){
    for(int i=index;i<=cnt;i+=lowbit(i))
        sum[i]+=val;
    return ;
}
int getSum(int index){
    int ans = 0;
    for(int i=index;i>0;i-=lowbit(i))
        ans+=sum[i];
    return ans;
}
int main(){
    while(~scanf("%d",&cnt)){
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=cnt;i++)
            scanf("%d",&a[i]);

        int ans=0;
        for(int i=cnt;i;i--){
            ans+=getSum(a[i]);
            update(a[i],1);
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值