HDU 1711 (数组+ KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21148    Accepted Submission(s): 9055


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

Source
 

Recommend

题意:与字符串相似,找第二个数组b[m]在第一个数组a[n]中出现的位置,如果找不到,返回-1;
将KMP算法用在数组上,用法基本一样...    KMP我也是才看,等熟练了,总结,后面在补上...

代码:
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stdio.h>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

int a[1000010],b[10010];
int m,n,nex[10010];  ///这里不能用next[]表示,不然CE...估计是与C++内置标识符抵触了...

void Getnext()  
{
    int i=0,j=-1;
    nex[0]=-1;
    while(i<m)
    {
        if(j==-1 || b[i]==b[j])
        {
            i++;
            j++;
            if(b[i]==b[j])
                nex[i]=nex[j];
            else
                nex[i]=j;
        }
        else
            j=nex[j];
    }
}

int KMP()
{
    int i=0,j=0;
    while(i<n)
    {
        if(a[i]==b[j])
        {
            if(j==m-1)
                return i-j+1;
            i++;
            j++;
        }
        else
        {
            j = nex[j];
            if( j == -1 )
            {
                i++;
                j=0;
            }
        }
    }
    return -1;
}

int main()
{
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(i=0; i<m; i++)
            scanf("%d",&b[i]);

        if( n<m )
            printf("-1\n");
        else
        {
            Getnext();
            printf("%d\n",KMP());
        }
    }
    return 0;
}


评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值