POJ 2488 A Knight's Journey 搜索

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

poj2488

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

由于是任意起点,而且要求输出字典序最小的,所以从A1开始,并且尽量先搜索横坐标小的(因为横坐标写在前面),这样可以保证第一次搜出的结果就是字典序最小的。

这个题一开始写错了好久,在网上看别人的代码也看不出来自己哪错了。自己的输出总是横纵坐标相反(比如A3变成C1),还找了大神询问,最后发现是输入棋盘大小的时候搞反了,自己的程序搜索的棋盘正好是要求的棋盘旋转了90度,所以横纵坐标正好相反。。。。以后要好好学习英语,只看懂题的大意还是不够。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <map>
#include<queue>
using namespace std;
int xa,ya;
bool isok[30][30];
char res[2][30];
bool flag;
int xx[8]={-2,-2,-1,-1,1,1,2,2};
int yy[8]={-1,1,-2,2,-2,2,-1,1};
void dfs(int x,int y,int cnt)
{
    res[0][cnt]=x+'A';
    res[1][cnt]=y+'1';
    if(cnt==(xa*ya-1))
    {
        flag=true;
        return;
    }
    for(int i=0;i<8;i++)
    {
        int g=x+xx[i];
        int h=y+yy[i];
        if(g>=0&&g<xa&&h>=0&&h<ya&&isok[g][h]&&!flag)
        {
            isok[g][h]=false;
            dfs(g,h,cnt+1);
            isok[g][h]=true;
        }
    }
}
int main()
{
    int t,time=1;
    cin>>t;
    while(t--)
    {
        cin>>ya>>xa;
        flag=false;
        for(int i=0;i<xa;i++)
            for(int j=0;j<ya;j++)
                isok[i][j]=true;
        isok[0][0]=false;
        printf("Scenario #%d:\n",time++);
        dfs(0,0,0);
        if(flag)
            for(int i=0;i<xa*ya;i++)
            {
                cout<<res[0][i]<<res[1][i];
            }
        else printf("impossible");
        cout<<endl<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值