ZOJ 1002 fire net DFS

Fire Net

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city;n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2

4

题目大意:

地图上有墙和空地,要在里面放置碉堡,碉堡可以攻击到四个方向,但是攻击会被墙挡住。规则是碉堡不能互相攻击到。求可以放置的最多的碉堡数量。

一开始采用了把攻击范围标记出来的方式,但是还原的开销太大,还是使用了判断的方法。

而且一开始直接用坐标x,y,很难写递归。后来发现网上有用一个数表示坐标的办法,这样写结束条件也变得简单。

#include <iostream>
#define wall 0
#define empty 1
#define put 2
using namespace std;
int n;
int isok[5][5];
int maxn;
bool canput(int x,int y)
{
    if(isok[x][y]==wall)
        return false;
    for(int i=x-1;i>=0;i--)
    {
        if(isok[i][y]==wall)
            break;
        if(isok[i][y]==put)
            return false;
    }
    for(int i=x+1;i<n;i++)
    {
        if(isok[i][y]==wall)
            break;
        if(isok[i][y]==put)
            return false;
    }
    for(int i=y-1;i>=0;i--)
    {
        if(isok[x][i]==wall)
            break;
        if(isok[x][i]==put)
            return false;
    }
    for(int i=y+1;i<n;i++)
    {
        if(isok[x][i]==wall)
            break;
        if(isok[x][i]==put)
            return false;
    }
    return true;
}
void dfs(int k,int cnt)
{
    if(k==n*n)
    {
        if(maxn<cnt)
        {
            maxn=cnt;
            return;
        }
    }
    else
    {
        int x=k/n;
        int y=k%n;
        if(canput(x,y))
        {
            isok[x][y]=put;
            dfs(k+1,cnt+1);
            isok[x][y]=empty;
        }
        dfs(k+1,cnt);
    }
}
int main()
{
    while(cin>>n,n)
    {
        for(int i=0;i<n;i++)
        {
            char c;
            for(int j=0;j<n;j++)
            {
                cin>>c;
                if(c=='.')
                    isok[i][j]=empty;
                else if(c=='X') isok[i][j]=wall;
            }
        }
        maxn=0;
        dfs(0,0);
        cout<<maxn<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值