2016SDAU课程练习一1013

Problem N 

Problem Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 


Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
 


Input
Input is a sequence of lines, each containing two positive integers s and d.
 


Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
 


Sample Input
59 237
375 743
200000 849694
2500000 8000000
 


Sample Output
116
28
300612

Deficit


题意:统计全年盈利状况,对于每一个月来说,盈利S,或亏空D。
公司每五个月进行一次统计,全年共统计8次(1-5、2-6、3-7、4-8、5-9、6-10、7-11、8-12),
已知这8次统计的结果全部是亏空(盈利-亏空<0)。题目给出S和D,判断全年是否能盈利,如果能则
求出盈利的最大值,如果不能盈利则输出Deficit
输入:每月盈利和亏空的数值
输出:能最大盈利多少,亏空则输出Deficit


思路:其实就是全是亏空也可能盈利,只需要盈利的月所有盈利的大于所有亏损的就行,但又要保证每次统计都是亏损,所以挨个列列


感想:这个挺好想的,就是有点绕


AC代码:

#include<iostream>
#include<cstdio>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
int s,d;
int win()
{
    if(s*4<d) return 10*s-2*d;
    if(s*3<d*2) return 8*s-4*d;
    if(s*2<3*d) return 6*s-6*d;
    if(s<d*4) return 3*s-9*d;
    return -1;
}
int main()
{
    int t;
    while(cin>>s)
    {
    cin>>d;
    t=win();
    if(t<0)
    cout<<"Deficit"<<endl;
    else cout<<t<<endl;
    }
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值