2016SDAU编程练习二1005



Turn the corner 


Problem Description
Mr. West bought a new car! So he is travelling around the city.<br><br>One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.<br><br>Can Mr. West go across the corner?<br><img src=../../../data/images/2438-1.jpg><br>
 


Input
Every line has four real numbers, x, y, l and w.<br>Proceed to the end of file.<br>
 


Output
If he can go across the corner, print "yes". Print "no" otherwise.<br>
 


Sample Input
10 6 13.5 4<br>10 6 14.5 4<br> 


Sample Output
yes<br>no<br> 


Source
2008 Asia Harbin Regional Contest Online

 

题意:车转角问题,让他能拐过弯道

思路:其实主要是数学问题算公式

感想:相比搜索,二分真是好做多了

AC代码:

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
double PI=acos(-1.0);
double x,y,v,w;
double s (double a)
{
    return v*cos(a)+(w-x*cos(a))/sin(a);
}
int main()
{
    double r,l,mid,midd;
    while(cin>>x>>y>>v>>w)
    {
        l=0;r=PI/2;
        while(r-l>0.0000001)
        {
            mid=(r+2*l)/3;
            midd=(l+r*2)/3;
            if(s(mid)>s(midd))
                r=midd;
            else
                l=mid;
        }
        if(s(l)>y) cout<<"no"<<endl;
        else cout<<"yes"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值