第七道ACM程序题

1.题目编号:1001和1008
Problem Description


There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).


 


Input


The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.


 


Output


The output should contain the minimum setup time in minutes, one per line.


 


Sample Input


  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1


 


Sample Output


  
  
2 1 3



2.简单题意:n根木棒,已知它们的长度和重量,用一部木工机一根一根地加工,在加工的过程中需要一定的准备时间,第一根木棒需要1min的时间,如果接下来的木棒比前面的木棒长度和质量都大则不需要任何的准备时间,否则需要1min的准备时间,求n根木棒加工所需要的最短的时间。

3.解题思路形成过程:这个也是一个可以用贪心算法的题目,首先用一个结构体将木棒的长度和重量表示出来,将所有木棒放在一个数组里面,最后将木棒分组,找出最大的分组序列。

4.感悟:这个也是老师上课讲的题目,用的方法就是老师给讲的,不光用了贪心算法,排序之后还用了动态规划的算法,这个算法老师好像第三专题开,早点接触也不错,(*^__^*) 嘻嘻,专题一,有两道这个题,题号为1008的老是语法错误,我就问了一下同学,他让我把memory.h换成从cstring,果然就过了,哈哈,还是懂得少,原来,memory.h是vc特有的,用c标准里的string.h就ok了。

5.AC的代码:

#include<iostream>
#include<algorithm>
#include<memory.h>
using namespace std;
struct stick{
    int l;
    int w;
};
stick data[5001];
int cmp(stick a,stick b){
    if (a.l==b.l)
    return a.w<b.w;
    else if (a.l<b.l)
    return true;
    return false;
}
void  max(int n,stick c[]){
    int b[5001];
    memset(b,0,sizeof(b));
    int i,j,k;
    b[0]=1;
    for (i=0;i<n;i++){
        k=0;
    for (j=0;j<i;j++)
    if (c[i].w<c[j].w&&k<b[j])
    k=b[j];
    b[i]=k+1;
    }
    int max=0;
    for(i=0;i<n;i++)
        if (b[i]>max)
        max=b[i];
        cout<<max<<endl;
    }
int main(){
    int T,l,w,n;
    cin>>T;
    while(T--){
        cin>>n;
        for (int i=0;i<n;i++){
            cin>>l>>w;
            data[i].l=l;
            data[i].w=w;
        }
        sort(data,data+n,cmp);
        max(n,data);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值