HDOJ 1091 A+B for Input-Output Practice (III)



Problem Description
Your task is to Calculate a + b.
 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
  
  
1 5 10 20 0 0
 

Sample Output
  
  
6 30
 

Author
lcy


虽然是水题,第一遍做的时候竟然WA了,那就把错误的代码拿出来大家也留意。。。

#include <iostream>
using namespace std;

int main()
{
    int a,b;
    while((cin>>a>>b)&&(a!=0&&b!=0))
        cout << a+b << endl;
    return 0;
}

运行后发现输入0和一个非0数的时候,程序结束。认真想了想,逻辑有问题,改了后果断AC。

#include <iostream>
using namespace std;

int main()
{
    int a,b;
    while((cin>>a>>b)&&(a!=0||b!=0))
        cout << a+b << endl;
    return 0;
}


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
   
   
1 5 10 20 0 0
 

Sample Output
   
   
6 30
 

Author
lcy
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值