ACM的A+B问题

两个基本的ACM的A+B问题

Problem Description

Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Inpu
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15

参考代码块
#include<stdio.h>
void  main(){     
    int i,n,a,sum=0;
    while(scanf("%d",&n)!=EOF){
        if(n!=0){
            for(i=0;i<n;i++){
                scanf("%d",&a);
                sum+=a;
            }
            printf("%d\n",sum);
            sum=0;
        }
        else break;
    }
}

Problem Description

Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10

15

6
参考代码块

#include<stdio.h>
int main(){
    int i,j,k,N,M,x,s[1000];
    scanf("%d\n",&N);
    for(j=0;j<N;j++){
        s[j]=0;
        scanf("%d",&M);
        for(i=0;i<M;i++){
            scanf("%d",&x);
            s[j]+=x;
        }
    }
    for(i=0;i<N-1;i++)
        printf("%d\n\n",s[i]);
    printf("%d\n",s[N-1]);
    return 0;
}

在做ACM试题时应注意输入的格式,有时需要使用while(scanf(“%..”,&..)!=EOF){…}进行循环输入操作,因为测试数据有多组。

  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值