HDU 4027 Can you answer these queries? 题解(思维+线段树区间更新)

11 篇文章 1 订阅



Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 15021    Accepted Submission(s): 3526


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6


题意:给定100000个数,两种操作,0 i j表示将i j这段的数字都开根号(向下取整),1 i j表示查询i j之间的所有值的和。。。(所有的和都不超过64位)..

分析:开根只能一个一个开。。。此题的关键是要理解对任何64位以内的值,开根号最多不会超过7次,所以用线段树做,更新到叶子节点的次数最多7次,所以,每次查询如果开根号的次数很多了就直接返回,否则继续往下更新到叶子节点。。。每次如果 开根之后 <= 1就不必更新了,把这点延迟标记了,向上更新的时候,这个lazy也要传递,当他的两个儿子都被mark的时候,他自己也被mark,这样下次就不必更新了。。注意代码的写法


#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#define lch rt*2,l,m
#define rch rt*2+1,m+1,r
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 5;
ll tree[maxn*4];
int mark[maxn*4];
void pushup(int rt)
{
    tree[rt] = tree[rt*2] + tree[rt*2+1]; //向上更新, 是 =, 根节点就等于左右子树想加。。。 
    mark[rt] = mark[rt*2] && mark[rt*2+1];
}
void built(int rt, int l, int r)
{
    mark[rt] = 0;
    if(l == r)
    {
        scanf("%lld", &tree[rt]);
        return ;
    }
    int m = (l+r)/2;
    built(lch);
    built(rch);
    pushup(rt);
}
void update(int rt, int l, int r, int i, int j)
{
    if(l == r)
    {
        tree[rt] = sqrt(tree[rt]);
        if(tree[rt] <= 1)
            mark[rt] = 1;  //小于<=1就没必要更新了
        return;
    }
    int m = (l+r)/2;
    if(i <= m && !mark[rt]) update(lch, i, j); //如果没被标记更新,标记了就不必更新了, mark标记用在这里的。。。
    if(j > m && !mark[rt]) update(rch, i, j);
    pushup(rt);
}
ll query(int rt, int l, int r, int i, int j)
{
    if(l >= i && r <= j)
    {
        return tree[rt];
    }
    int m = (l+r)/2;
    ll ans = 0;
    if(i <= m) ans += query(lch, i, j);  //查询的时候 肯定每个都要查询。。
    if(j > m) ans += query(rch, i, j);
    return ans;
}
int main()
{
    int n, k = 1;
    while(~scanf("%d", &n))
    {
        built(1, 1, n);
        int m;
        scanf("%d",&m);
        int flag = 1;
        while(m--)
        {
            int t, x, y;
            scanf("%d%d%d",&t,&x,&y);
            if(x > y) swap(x, y);  //没说哪个大哪个小
            if(t == 0)
            {
                update(1,1,n,x,y);
            }
            else
            {
                if(flag == 1)  {printf("Case #%d:\n",k);flag = 0;}
                printf("%lld\n",query(1,1,n,x,y));
            }
        }
        k++;
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值