poj 3278 Catch That Cow

题目链接:http://poj.org/problem?id=3278

题目描述:

 

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

题目大意:

 

给定一个数N (O≤N≤100000),变成另一个数K(O≤K≤100000),允许的操作是乘以2,或者加减1,问最少要几步才能完成?

 

题目分析:

bfs,注意剪纸和控制数组的大小

 

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n,k,step;
int q[400005],dis[400005],visit[400005];
int bfs(int m)
{
    int front=0,rear=1;
    q[front]=m;
    dis[m]=0;
    visit[m]=1;
    while(front<rear)
    {
      m=q[front++];
      if(!visit[m*2]&&m<k)
    {
        q[rear++]=m*2;
        visit[m*2]=1;
        dis[m*2]=dis[m]+1;
        if(m*2==k)
            return dis[m*2];
    }
    if(!visit[m+1]&&m<k)
    {
        q[rear++]=m+1;
        visit[m+1]=1;
        dis[m+1]=dis[m]+1;
        if(m+1==k)
            return dis[m+1];
    }
    if(!visit[m-1]&&m>0)
    {
        q[rear++]=m-1;
        visit[m-1]=1;
        dis[m-1]=dis[m]+1;
        if(m-1==k)
            return dis[m-1];
    }
    }
    return -1;
}


int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(visit,0,sizeof(visit));
        memset(dis,0,sizeof(dis));
        if(n>=k)
            printf("%d\n",n-k);
        else
        {
            printf("%d\n",bfs(n));
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值