C - Catch That Cow POJ - 3278 (bfs)

C - Catch That Cow

 POJ - 3278 

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <iostream>
#include <string.h>
#include <queue>
using namespace std;

struct node
{
    int x,step;
};

node n,m;
int a,b;
int flag[100010];

void bfs()
{
    queue<node>q;
    n.x=a;
    n.step=0;
    q.push(n);
    flag[n.x]=1;
    while(!q.empty())
    {
        m=q.front();
        q.pop();
        if(m.x==b)
        {
            cout << m.step;
            return ;
        }
        for(int i=1; i<=3; i++)
        {
            if(i==1)
            {
                n.x=m.x+1;
            }
            if(i==2)
            {
                n.x=m.x-1;
            }
            if(i==3&&m.x!=0)
            {
                n.x=m.x*2;
            }
            if(n.x>100000||n.x<0)//必须要加,且不能用break
            {
                continue;
            }
            if(flag[n.x]==0)
            {
                flag[n.x]=1;
                n.step=m.step+1;
                q.push(n);
            }
        }
    }
}

int main()
{
    memset(flag,0,sizeof(flag));
    cin >> a >> b;
    bfs();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值