zoj 3609 Modular Inverse(逆元)

Modular Inverse

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8
 
题意:求ax≡1(mod m) 直接用逆元

#include<cstdio>
#define LL long long
int flag=0;
int GCD(int a,int b,int &x,int &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		if(a==1)
		   flag=1;
		return a;
	}
	int r=GCD(b,a%b,x,y);
	int tem=x;
	x=y;
	y=tem-a/b*y;
	return r;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		flag=0;
		int a,m;
		scanf("%d%d",&a,&m);
		int x,y;
		GCD(a,m,x,y);
		x=x%m;
		if(x<=0)  //判断x的正负 
		  x+=m;
		if(flag==0)
		   printf("Not Exist\n");
		else 
		   printf("%d\n",x);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值